2012 V200 duel cab - No turbo kick in when cold

Chat about engines, exhaust and fuel system related issues in Great Wall X240, V240, X200 and V200 vehicles

2012 V200 duel cab - No turbo kick in when cold

Postby amandadeanholidays » Tue Jul 24, 2018 7:11 pm

Hi there, for the past couple of weeks I have started my V200 2012 but the turbo does not kick in. The yellow spanner lights up. When I come to hills, I have to shuffle between 1st and 2nd gear to get me to the top. I then leave the car whilst I go to work then I start the motor at the end of the day to return home and the turbo kicks in and the car runs well. Sometimes if I rev the engine above 2000revs whilst at lights then suddenly let the clutch out the turbo works but I need to keep the revs above 2000 to keep the turbo going.
Has anyone had this problem??
amandadeanholidays
 
Posts: 1
Joined: Tue Jul 24, 2018 6:08 pm

Re: 2012 V200 duel cab - No turbo kick in when cold

Postby Jason » Wed Jul 25, 2018 9:28 am

Best to get the fault codes checked to be sure, but I have a simple something you can try.

If the brake switch is not made when the brake pedal is released it can produce similar symptoms to what you describe. A small adjustment of the screw (1/4 turn) can shift the simple in the face clear of the switch.

Good luck
Jason
Great Wall Convert
Great Wall Convert
 
Posts: 19
Joined: Tue Jul 04, 2017 7:48 pm


Return to Engine, Exhaust And Fuel Systems

Who is online

Users browsing this forum: No registered users and 5 guests