Just had the ECU upgrade on my V200

Chat about engines, exhaust and fuel system related issues in Great Wall X240, V240, X200 and V200 vehicles

Re: Just had the ECU upgrade on my V200

Postby neoppg » Wed Mar 07, 2012 12:08 pm

Ok... Picked mine up an hour ago from the factory reflash and there is an immediate difference on take off ..... Very happy now I must say..... It's obviously not a huge power plant with a 2ltr motor but it now takes off like it should without or little delay..... Thanks to the guys at Springwood Keema.
Image
V200 "Loving It"
neoppg
Great Wall Wizard
Great Wall Wizard
 
Posts: 80
Joined: Wed Feb 01, 2012 1:07 pm

Re: Just had the ECU upgrade on my V200

Postby Great72Q » Thu Mar 08, 2012 8:27 pm

Mine had the re-flash o Monday at 15K service, noticable difference straight away and much improved in traffic at low speed. So far 700 klms and used 3/4 tank so fuel usage is about the same.
Great72Q
 
Posts: 2
Joined: Wed Dec 21, 2011 7:54 pm

Re: Just had the ECU upgrade on my V200

Postby MRTbrett » Sat Mar 10, 2012 3:39 pm

The post November cars already have the "revised ECU update" hence why its only offered to pre Nov cars
:)
MRTbrett
Great Wall Convert
Great Wall Convert
 
Posts: 8
Joined: Sat Mar 10, 2012 2:18 pm

Re: Just had the ECU upgrade on my V200

Postby hairy » Fri Mar 23, 2012 10:56 am

Just had ours done yesterday and now I feel all able to have response down low in the rpm's. In the past I had to have the V200 in 4 Low :evil: to climb a small hill that I was able to climb in a Mazda 323 81' :lol: and Mitsubishi(t) Sigma :o this has now changed THANK GOD!
As smooth as Silk, as sincere as Polyester!
hairy
Great Wall Fan
Great Wall Fan
 
Posts: 41
Joined: Tue Sep 20, 2011 10:02 am
Location: South East suburbs Melbourne, formally the best farming land in the country.

Re: Just had the ECU upgrade on my V200

Postby ndelahun » Fri Mar 23, 2012 1:14 pm

Well Had the reflash a week ago done and could immediately tell the difference. Low Level boost seems to cut in at about 1600 rpm.I do a lot of Travel between Bathurst and Orange so it is a bit hilly there and I did notice a bit of a loss in the climbing the hills initially but after about 600km's it seems to be climbing the hills really well now.
ndelahun
Great Wall Convert
Great Wall Convert
 
Posts: 16
Joined: Fri Dec 09, 2011 6:44 pm

Re: Just had the ECU upgrade on my V200

Postby SamuelGWV200 » Fri Apr 06, 2012 12:53 pm

Im about to buy a great wall v200 dual cab ute 2011 model, the ECU upgrade is that something that my Dealer will know about? how did you hear about the ECU upgrade?
i found this on ebay
GREAT WALL V200 2.0 DIESEL 105kW Chip Box Power Tuning Performance Chippower100
Is this what they will install?
SamuelGWV200
 
Posts: 2
Joined: Thu Apr 05, 2012 7:15 pm

Re: Just had the ECU upgrade on my V200

Postby V200 » Fri Apr 06, 2012 6:16 pm

Hi Samuel,

No. As a dealer they have access to factory scantools and can reprogram the ECU. The unit on eBay will void your warranty. If you do a search on the forum you can find discussions about this and similar items.

As stated above, any vehicle post Nov 11 should have the new software, so if you bought one now it should be right. Do remember that these are only a 2 litre, so is takes some revs to get the gas flow up - compare it to the amarock and you'll see it suffers similarly.
Kind Regards

John
V200 Dual Cab 4x4 in Blue.
Image
V200
Great Wall Evangelist
Great Wall Evangelist
 
Posts: 904
Joined: Sat Aug 13, 2011 6:17 pm
Location: Geelong, Victoria

Re: Just had the ECU upgrade on my V200

Postby Rayburger » Sun Apr 08, 2012 6:11 am

Just got my ecu upgrade ,did notice a difference in 1st gear taking off ,bit more grunt but everything else appears to be normal
Image v200 2wd 2L TD 6 speed
Rayburger
Great Wall Convert
Great Wall Convert
 
Posts: 19
Joined: Sat Aug 20, 2011 4:46 pm
Location: Central QLD

Re: Just had the ECU upgrade on my V200

Postby Jonsta » Mon Apr 09, 2012 8:30 pm

Rayburger wrote:Just got my ecu upgrade ,did notice a difference in 1st gear taking off ,bit more grunt but everything else appears to be normal


First gear is a real problem for me. Even after the flash, theres just no acceleration in first gear! It's anemic until 1800RPM, and then it takes off suddenly making me look like a hoon. :( Everything else is perfect except there's just not enough get-up-and-go for pulling out into roundabouts or nagivating tight spots.

Jonsta
"The Big Stupid Great Wall"
Image
Jonsta
Great Wall Evangelist
Great Wall Evangelist
 
Posts: 250
Joined: Sat Sep 24, 2011 3:55 pm
Location: Logan, QLD

Re: Just had the ECU upgrade on my V200

Postby Robbo » Mon Apr 09, 2012 9:54 pm

maybe they didnt actually do the tune?, take it back in and ask them to check
black budget/Swampy,
Image

extras, OAQ steel winch bar, tow bar, 2000 W amp and sub, carbon tint, 9" (now 55W HID ) spotlights, cruise control.....a clock. and "RMW"bits
Robbo
Great Wall Evangelist
Great Wall Evangelist
 
Posts: 1608
Joined: Fri Jan 07, 2011 10:36 pm
Location: NWQ

PreviousNext

Return to Engine, Exhaust And Fuel Systems

Who is online

Users browsing this forum: No registered users and 2 guests