Radio will not turn on after replacing battery

Wiring, batteries, console and Great Wall compatible electronic gadgets discussion.

Radio will not turn on after replacing battery

Postby Sail100 » Sat Feb 18, 2017 9:46 pm

Hi All,
It's been a while since I have needed to post a request for assistance. I find myself in need of some advice I have replaced my battery today and now find the radio will not turn on. The reversing camera still is operating. My vehicle is a 2012 X200 any advice will be much appreciated. Have checked the fuse in the side dashboard panel all ok.
Image
Ian
Sail100
Great Wall Convert
Great Wall Convert
 
Posts: 15
Joined: Mon Sep 03, 2012 4:04 pm
Location: Bradbury NSW

Re: Radio will not turn on after replacing battery

Postby X240rob » Sun Feb 19, 2017 7:51 am

do you need to put in security code?
most radios with security will not turn on after disconnecting battery.
but they usually have notice come up on the screen.

I have a series 1 so different radio to you.
2010 X240, lifted about 2", snorkel, roof rack, awning and "light bar", bouncing about the APY Lands
1974 280SEL Mercedes Benz,
http://i108.photobucket.com/albums/n35/ ... %20av2.jpg
X240rob
Great Wall Evangelist
Great Wall Evangelist
 
Posts: 654
Joined: Wed Jan 05, 2011 1:50 pm
Location: Pipalyatjara, APY Lands, SA

Re: Radio will not turn on after replacing battery

Postby Sail100 » Sun Feb 19, 2017 10:04 am

Thanks but unfortunately I only have a blank screen
Image
Ian
Sail100
Great Wall Convert
Great Wall Convert
 
Posts: 15
Joined: Mon Sep 03, 2012 4:04 pm
Location: Bradbury NSW

Re: Radio will not turn on after replacing battery

Postby pal » Mon Feb 20, 2017 6:05 am

Sorry I can't help you, I changed my battery aout 3 months ago and had no problems . Mine is a 2012 X200 auto
Harold

Image
pal
Great Wall Wizard
Great Wall Wizard
 
Posts: 87
Joined: Sun May 12, 2013 7:23 am
Location: Bundaberg

Re: Radio will not turn on after replacing battery

Postby Escapable » Tue Feb 28, 2017 10:22 pm

Sail100 wrote:Hi All,
It's been a while since I have needed to post a request for assistance. I find myself in need of some advice I have replaced my battery today and now find the radio will not turn on. The reversing camera still is operating. My vehicle is a 2012 X200 any advice will be much appreciated. Have checked the fuse in the side dashboard panel all ok.


Ok.. so here is the simple facts regarding the GW Radio:

It is NOT connected to the the vehicles CAN bus - it is connected to the power, speakers and rear cam.
If it does not turn on, suggest disconnecting and retry again, otherwise check connections to the connector at the radio, it is a "dumb" device. If it does not operate but the cam does, remove and service the radio - no security codes are involved.
Blue X200 Auto 2013 (Pro Racing OBD Chipped)
Most cars are assembled from Chinese parts: Why not bring in the whole car?
Escapable
Great Wall Legend
Great Wall Legend
 
Posts: 182
Joined: Fri Jan 24, 2014 9:30 pm

Re: Radio will not turn on after replacing battery

Postby rasho » Fri Aug 18, 2017 10:12 pm

Tarnish build up on the contacts of on/off switch. Hold switch on and rotate dial and or jiggle switch. This might clear some tarnish and allow electrical contact. Repeat a couple of times if need be.
rasho
 
Posts: 1
Joined: Fri Aug 18, 2017 9:57 pm


Return to Electrical and Electronic Systems

Who is online

Users browsing this forum: No registered users and 1 guest