X240 Electric Window Not Working

Wiring, batteries, console and Great Wall compatible electronic gadgets discussion.

X240 Electric Window Not Working

Postby Jimboblueangels » Wed Mar 25, 2015 4:52 pm

Hi
We recently bought an x240. Very soon we had an intermittent problem with the drivers window switch not responding and the window being stuck in any position and not being able to operate it with the switch. It has now become a permanent problem. When the switch is pressed to lower the window it makes a mad clicking like a relay going mad and then the central locking starts locking and unlocking itself. I bought a second hand switch unit and swapped them but I have the same problem. Has anybody experienced this?
Thanks in advance
Jim
Jimboblueangels
 
Posts: 1
Joined: Wed Mar 25, 2015 4:45 pm

Re: X240 Electric Window Not Working

Postby X240rob » Wed Apr 22, 2015 5:42 pm

I would suggest getting the wiring from the car to the door checked out. ie in the door jam.
Ours recently has had intermittent problems with drivers door window switches. The window switches will only work with door open. Which suggests wiring fatigue.
I have heard if similar issues.
Our car is a 2010 X240 with 145000km.
I have not had time to investigate further.
2010 X240, lifted about 2", snorkel, roof rack, awning and "light bar", bouncing about the APY Lands
1974 280SEL Mercedes Benz,
http://i108.photobucket.com/albums/n35/ ... %20av2.jpg
X240rob
Great Wall Evangelist
Great Wall Evangelist
 
Posts: 654
Joined: Wed Jan 05, 2011 1:50 pm
Location: Pipalyatjara, APY Lands, SA

Re: X240 Electric Window Not Working

Postby X240rob » Sun May 03, 2015 5:03 pm

Had a bit of a play today. Thought I better get into it, stopped to chat to the local copper and had to open the door to wind window down. He was unfazed, like most other cars out here!!
Could not find a "broken" wire.
They all checked ok continuity wise. maybe the bending etc to get to the plug connection out from the car side.

I then re-taped the loom on the door side, this should reduce the tight bending of the loom.
After putting it all back together it works ok.

Could have also been a bad connection at the door to car loom connector.
2010 X240, lifted about 2", snorkel, roof rack, awning and "light bar", bouncing about the APY Lands
1974 280SEL Mercedes Benz,
http://i108.photobucket.com/albums/n35/ ... %20av2.jpg
X240rob
Great Wall Evangelist
Great Wall Evangelist
 
Posts: 654
Joined: Wed Jan 05, 2011 1:50 pm
Location: Pipalyatjara, APY Lands, SA

Re: X240 Electric Window Not Working

Postby Mitcon » Mon May 04, 2015 6:01 am

The front passenger window on my V240 was playing up and not responding just a couple of days ago, scratching my head I'm wondering where to check first. Wiring loom, Hmmmm, contacts in the switch itself and then I remembered I hadn't lube'd the rubber channels with silicone for ages.

So did that first as it's easiest, my favourite place to start lol and after squirting the rubbers all good again. Sod was just sticking in the channels.
Cheers
Wayne


Go low, Go slow.
Mitcon
GWOF Co-founder
GWOF Co-founder
 
Posts: 1607
Joined: Sun Sep 12, 2010 3:18 pm
Location: Southern Adelaide

Re: X240 Electric Window Not Working

Postby Greatwallpeter » Mon Feb 08, 2016 1:36 pm

Hello I own x240 had switch problem it was not switch for window but the pin on main door jam power connection arching and sometimes making contact new plug in door jam all fixed check this before ordering new door switch no more stuck Windows
Greatwallpeter
 
Posts: 1
Joined: Mon Feb 08, 2016 1:28 pm

Re: X240 Electric Window Not Working

Postby Mallory » Thu Apr 21, 2016 8:32 pm

Hi All,
I have exactly the same problem right down to the central locking going
nuts, I ended up pulling everything apart and found the computer card under
the window buttons was only working intermittently. I used the card buttons
manually and it worked ok, put it all back together again and the window
button didn't work.....pulled it all apart again and tried the card buttons
manually again but it didn't work.....put it all back together again and
hey presto the window button worked again....but only for a few days then
stopped working yet again. So I have a custom cut stick holding the window
up and no door trim on.
I have tried to locate the window computer card on after market sites but
no joy. It has HYEC HD8.152.005 printed on it.
If anyone knows where I could get one let me know please as the whole
window button assembly from Great Wall is $195.00

I also have the situation where the drivers door does not work with the
central locking so I have to lock the car with the key only.

Anyone got any advice

Cheers
Gazza
Mallory
 
Posts: 1
Joined: Thu Apr 21, 2016 11:02 am

Re: X240 Electric Window Not Working

Postby didjis62 » Tue Jun 13, 2017 9:14 pm

Hi mate,i maybe a bit late to offer a hand but try this link, may help you
https://www.aliexpress.com/item/Great-W ... -anti-trap
didjis62
 
Posts: 3
Joined: Thu Mar 09, 2017 10:17 am


Return to Electrical and Electronic Systems

Who is online

Users browsing this forum: No registered users and 2 guests